تهيه کننده

رضا شرفي

منابع
www.delphi-magic.com
www.fast-report.com


 fast report آموزش

اين کامپوننت بدون شک يکي از قويترين ابزار هاي گزارشگيري در دلفي و سي بيلدر است و کار با آن بسيار راحت و
کاربر رپسند است در زير به چند مزيت و برتري آن اشاره مي کنيم

پشتيباني کامل از زبان فارسي

قابل استفاده در زمان طراحي  و اجرا
قابليت محيط کاملا فارسی

(csv-gif-txt-html-Excel-rtf-tif-jpg-pdf) خروجي از گزارش به چند فرمت  مختلف

آموزش نصب کامپوننت fast report

فارسي کردن محيط برنامه

با اجراي فايل recompile.exe  ابتدا  زبان مورد نظر را از کمبو باکس انتخاب نموده و سپس رگزينه کامپايل را انتخاب ميکنيم

توجه
دقت نماييد که هنگام اجراي اين فايل برنامه دلفي باز نباشد در غير اين صورت لطفا قبل از اجراي فايل بال حتما برنامه ببنديد

اگر  مراحل بالا را به درستي انجام داده با شيد يک پيغام مبتني بر  موفقيت آميز بودن مراحل فوق دريافت خواهيد کرد

حال به پوشه libD7رفته و فايلهاي موجود رو بهد پوشه سورس انتقال دهيد

زماني که برنامه نصب شد براي اينکه در زمان نصب کامپوننت به مشکل بر نخوريد
 لطفاتمامي فايلهاي موجوددر پوشه هاي زير را در يک پوشه واحدوبانام دلخواه بريزيدتامراحل نص ب را از درون آن پوشه شروع کنيم

حال فايل هاي زير را يکي يکي نصب کنيد که پکيج هاي زير مربوط به زمان طراحي هستند (Design Time)

توجه
دقت کنيد که علامت * معرف نسخه دلفي شماست

Dclfs*.dpk
DclfsDB*.dpk
DclfsDBE*.dpk
DclfsADo*.dpk
DclfsIBX*.dpk
Dclfrx*.dpk
DclfrxDB*.dpk
DclfrxDBE*.dpk
DclfrxADo*.dpk
DclfrxIBX*.dpk
DclfrxDBX*.dpk
Dclfrxe*.dpk

پس از دوبار  کلیک روی هر کدام از فایل های فوق ابتدا گزینه Comil و سپس گزینه  Install نمایید

بعد از نصب هر کامپوننت می بایست یک پیغام مبنی بر موفقیت آمیز بودن نصب در یافت نمایید


fast report نکات مهم و روش استفاده از متد ها و خصوصيت هاي

نمايش و ذخيره يک گزارش
                                                                              frxReport1.loadFromFile ('c:\1.fr3');

  frxReport1.saveToFile ('c:\2.fr3')  ;

فراخواني صفحه طراح گزارش

frxReport1.showreport;

پيش نمايش گزارش

If frxReport1.preparereport then
Frxreport1.shopreparedReport;

چاپ گزارش
    FrxReport1.print;

فراخواني و ذخيره فايل يک گزارش چاپ شده

Function loadfromFile (const File Name: string; ExceptionIfnotFound:Boolean=false); Boolean;
Procedure save to File(const FileName :string);
Procedure Loadfromstream (stream: TStream);
Procedure savetostream: tstream);
Frxreport1.previwpages.loadFromFile ('c: \1.fp3');
Frxreport1.showpreparedreport;

خروجي گرفتن به فرمتهاي مختلف از گزارش

frxReport1.Export(frxHTMLExport1);

تغيير کاغذ بصورت خوايبده يا ايستاده
     page.orientation:=polandscape;

ايجاد يک صفحه منحصر به فرد مانند توابع تصادفي
      page.createUniqueName;

برگرداندن  به حالت پيش فرض

    page.SetDefaults;

نمايش  يک گزارش
   frxReport1.showReport;
                                                       تغيير چينش چپ براست يک شي
 Memo.HALign:=haRight;

به پايگاه داده

Memo.Dataset:=frxDBDataset1;
Memo.Datafield:= 'CustNo';
Memo.setBounds (0,0,100,20);

اضافه کردن يک  شي به باند داده اصلي
Memo: =TfrxMemoView.Create (DataBand);
Memo.CreareUniqueName;

اضافه کردن يک صفحه خام  به گزارش
 page:= TfrxReportPage.Create(frxReport1)

اضافه کردن يک صفحه ديتا به گزارش
        Datapage:=TfrxDatapage.Create(frxReport)